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Small Engine Management Evaluation Board 

User Manual for TLE8082ES+TLE8080EM Evaluation Board  

About this document  

This document explains how the Evaluation Board of TLE8082ES + TLE8080EM is taking into operation. The 
required hardware and software components for the evaluation are documented. For a detailed description of 

the hardware components, see the datasheets of TLE8080EM and TLE8082ES s. 

Intended audience 

This document is intended for anyone who uses Infineon’s small engine management solution. The Evaluation 

board uses TLE8080EM and its brand new companion IC TLE8082ES to provide a comprehensive motorcycle 
engine control design.
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1 Hardware 

Figure 1 provides an overview on the TLE8082ES+TLE8080EM Evaluation board. 

 

Figure 1 Functional component blocks on the Evaluation PCB 

The Evaluation board provides an Arduino pinout form factor. It can be controlled with every Arduino 

compatible microcontroller board. Infineon provides a control software for two different microcontroller 
boards: XMC1100 Boot Kit and Aurix ShieldBuddy TC275. Figure 2 and Figure 3 show the hardware setup of both 
variants. 
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1.1 XMC Hardware setup 
 

 

Figure 2 Illustration of XMC Hardware setup 

 

 

Figure 3 Illustration of Aurix Shield Buddy Hardware setup  
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1.1.1 Output connectors 

The Evaluation board provides two power connectors to drive inductive and/or resistive loads with TLE8080EM 

and TLE8082ES 

                

Figure 4 TLE8082ES - Output Connector X1 (left), TLE8080EM Output connector X2 (right) 

Table 1 TLE8082ES - Output connector X1 

Output of 

TLE8082ES 

Pin no. Description 

PGND X1-5 Power ground signal – optional use if GND ≠ PGND (open R23) or use as additional GND 

connection 

OUT1 X1-4 Status of output stage 1 of TLE8082ES 

OUT2 X1-3 Status of output stage 2 of TLE8082ES 

OUT3 X1-2 Status of output stage 3 of TLE8082ES 

OUT4 X1-1 Status of output stage 4 of TLE8082ES 

Table 2 TLE8080EM - Output connector X2 

Output of 

TLE8082ES 

Pin no. Description 

OUT1x X2-5 Status of output stage 1 of TLE8082EM 

OUT2x X2-4 Status of output stage 2 of TLE8082EM 

OUT3x X2-3 Status of output stage 3 of TLE8082EM 

OUT4x X2-2 Status of output stage 4 of TLE8082EM 

OUT5x X2-1 Status of output stage 5 of TLE8082EM 
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1.1.2 Connector Interface for Arduino 

The Connector placement of the Evaluation PCB is compliant with the Arduino form-factor. The pinouts are 

listed below. 
 

 

Figure 5 Power Connector J502 

Table 3 Power supply Connector J502 

Pin no. Arudino Signal Name Evaluation PCB Signal Name Description 

1 - - - 

2 IOREF VIO Communication supply level (SPI) 

3 RESET RESET# External reset signal (low active) 
connected to NRIO. Reset of TLE8082ES 

and TLE8080EM (if R27 jumper 

assembled). 

4 3.3V +3.3V 3V3 volt supply – not used 

5 5V +5V 5V volt supply – not used 

6 GND GND Ground 

7 GND GND Ground 

8 VIN VBAT Voltage Level (usually 12V) applied to 

VS and KEY (if J1 is closed) 
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Figure 6 Communication Interface Connector J401  

Table 4 Communication Interface Connector J401 

Pin no. Arudino Signal Name Evaluation PCB Signal Name Description 

1 IO8 CS1# SPI Chipselect signal for multiply 
Evaluation PCB use. Note: R30 must be 

assembled. 

2 IO9 IN1 (TLE8082EM) PWM input connected to TLE8082EM 

IN1 

3 IO10 CS0# SPI Chipselect signal for TLE8082ES 

4 IO11 MOSI SPI Master Out Slave In 

5 IO12 MISO SPI Master In Slave Out 

6 IO13 SCLK SPI Clock  

7 GND GND Ground 

8 AREF AREF Analog reference – 5V by TLE8080EM 

9 SDA NRIO NRIO signal to microcontroller 

10 SCL NRO NRO signal to microcontroller 
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Figure 7 Digital IO Connector J402 

Table 5 Digital IO Connector J402 

Pin no. Arudino Signal Name Evaluation PCB Signal Name Description 

1 IO0 RX UART Receive – not used – can be 

connected to COM5V via J3 

2 IO1 TX UART Transmit – not used – can be 

connected to V5DD via J3 

3 IO2 VR_OUT TLE8080EM VR output signal – can be 

disconnected via R19 

4 IO3 PWM3  TLE8080EM IN3 

5 IO4 CSN80 SPI Chipselect signal for TLE8080EM 

6 IO5 PWM5 TLE8082ES IN1 

7 IO6 PWM6 TLE8082ES IN23 

8 IO7 PWM7 TLE8082ES IN4 
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Figure 8 Analog Connector J404 

Table 6 Analog Connector J404 

Pin no. Arudino Signal Name Evaluation PCB Signal Name Description 

1 AD0 COM5V Voltage of TLE8082ES COM5V 

2 AD1 T5V Voltage of TLE8082ES T5V 

3 AD2 V5DD Voltage of TLE8082ES V5DD 

4 AD3 CFB4 (current sense) Voltage of TLE8082ES CFB pin for 

current feedback 

5 AD4 KEY-ON Voltage of TLE8082ES KEY pin for on/off 

detection 

6 AD5 - Not connected 

7 - - - 

8 - - - 

1.1.3 Measurement and Jumper Options 

On the Evaluation PCB are various configuration options available for individual measurements or setup 

options, respectivly.  

The pin header J3 is intended to make signal available to ease the measurement with oscilloscope probes. 
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Figure 9 Measurement signal at J3 

Various test point allow an easy measurement of signals during evaluation. Following table describes the 

signals that can be measured via test points. 

Table 7 Measurement points 

Measurement signal Measurement Designation Description 

VR sensor interface of 

TLE8082EMES 

 VR_IN1 VR sensor signal 1 

 VR_IN2 VR sensor signal 1 

 VR_OUT Logic output signal swichted  according to to 

input voltage difference (VR_IN1 – VR_IN2) 

Current sense of 

TLE8082ESEM 

VCFB4 Voltage level proportional to current through 

output stage 4 of TLE8082ES 

Voltages VIN Input/Battery Voltage, usually 12 V 

VG Gate Voltage for Pre-regulator MOS-FET, 

usually 8 V 

VS Output voltage of Pre-regulator MOS-FET, 

usually 6 V 

VIO Voltage level for SPI output buffer, usually 5 V 
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The jumper options are descriped in the table below. 

Table 8 Jumper Options 

Jumper Jumper Designation Description 

KEY on signal J1 Close to wake up TLE8082ES 

Watchdog disable J2  Close to disable watchdog function of 

TLE8080EM 

Supply to external R21 (default open) Close to provide 5V to external via J502-5 

R24 (default open) Close to provide 5V to external via J502-2 

(VIO signal) 

Reset options R27 (default open) Connect TLE8082ES NRIO and TLE8080EM 

NRO to control TLE8082ES reset with 

TLE8080EM 

Arduino signals R17, R9, R10, R19, R20, R18, R30 Open/close for use of Arduino specific signal 

for other purposes 

1.1.4 LEDs 

The Evaluation board provides LEDs to indicate the voltage levels of TLE8082ES. The meaning of the status 

LEDs is descriped below. 

Table 9 LED description 

LED designation TLE8082ES Pin designation Description 

V5DD V5DD Glows if 5V of V5DD is active  

VIO VIO Glows if VIO voltage is active  

COM5V COM5V Glows if COM5V voltage is active 
 

1.2 Schematic and Layout 

This chapter provides the schematics and layout of the Evaluation board at a glance. 
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Figure 10  Schematic of the Evaluation Board 
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Figure 11 Layout Evaluation-PCB 
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2 Software 

The TLE8082EM2+TLE8082EM Evaluation board control software is available for two different Infineon 
microcontroller boards: 

 XMC setup for the use of e.g. XMC1100 Boot kit  

 Aurix ShieldBuddy: TC275 TriCore microcontroller board supporting the Aruduino form factor 

Both setup types require the use of an appropriate Arduino IDE such as the Standard Arduino IDE or Visual 

Studio including PlatformIO. This manual focuses on the Standard Arduino IDE. 

Each setup requires an according software environment to be installed on your machine. Depending on the 

setup you are using please follow the steps described in “2.1 - XMC setup” or “2.2 - Aurix ShieldBuddy TC275”, 

respectively. 

2.1 XMC setup 

The use of the XMC board setup requires the installation of the XMC-for-Arduino board information. Please 

follow the instruction at https://github.com/Infineon/XMC-for-Arduino to integrate the XMC board into your 

Arduino IDE.  The Ardunio Script for the XMC setup requires the use of the “Every Timer” Library. Please install it 
via the Arduino IDE Library Manager. 

 

Figure 12 Install the required EveryTimer Library 
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2.2 Aurix ShieldBuddy TC275 

The Aurix ShieldBuddy board requires the use of the “FreeEntryToolchain” to compile the Arduino Sketch 

correctly. If not done already, please install the FreeEntryToolchain to use the ShieldBuddy. Additionally, the 
Board information must be integrated in the used Arduino IDE. Therefore, please download and install the 
ShieldBuddyMulticoreIDE (Password: ShieldBuddy). Futher information can be found in the getting started 

guide for ShieldBuddy. 

2.3 Flash Arduino script 

Once the software environment has been successfully installed, please follow the below listed steps in the 
Standard Arduino IDE: 

 Select the microcontroller board you are using under Tools → Board.  

 Open the appropriate Arduino script (provided by Infineon) in the Arduion IDE via File → open.  

 Connect the microcontroller board to the PC via USB and select the correct COM port in the Arduino IDE 

under Tools → Port 

 Open the Serial Monitor in the Arduino IDE under Tools → Serial Monitor and select the correct baud rate in 
the lower right corner of the Seria Monitor 

o XMC setup: 230400 Baud 

o ShieldBuddy: 115200 Baud 

 Flash the script onto the microcontroller via Sketch → Upload 

 If the ShieldBuddy is used, please press the Reset button on the board 

The starting menu in the Serial Monitor pops up after successful flashing of the Arduino script. Figure 13  shows 

the start menu of the ShieldBuddy setup and Figure 14 shows the start menu of the XMC setup.  

The commands that can be send to the Evalboard follow a structure. First, the addressed device is specified (80: 

TLE8080EM, 82: TLE8082ES), followed directly by the actual command e.g. ch1 to switch the state of ch1. After a 
space the intended action is specified e.g. “0” to disable ch1. The main menu is clusterd into four main 

command sections: 

 PWM menu: control of TLE8082EM CH1/3 and TLE8082ES CH1/3 with specified PWM signal 

 SPI ON/OFF menu: on/off control of TLE8082EM CH2/4/5 and TLE8082ES CH2/4 via SPI 

 VRS menu: configuration of TLE8082EM VRS interface 

 COM5V/Tracker/AfterRun menu: control of voltage supply domains, afterrun option and diagnosis of all 

channels 

Please consider that the XMC software requires different commands than the ShieldBuddy software. The 
command nomenclature for the XMC setup is given under the section “Key-in”. 
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Figure 13 Start menu for Evalboard control via Serial Terminal - ShieldBuddy  

 

Figure 14 Start menu for Evalboard control via Serial Terminal – XMC 
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3 Application Example: Current Measurement with TLE8082 CFB 

The current feedback pin (CFB4) of TLE8082ES provides a pull down current which is directly proportional to 
the output current of channel 4. This information can be used e.g. to estimate the temperature of the applied 

output stage load (O2 heater). The evaluation board reads back the supply voltage VIN. The resistance of the O2 
heater can be calculated by using Ohms law. Figure 15 gives an overview how the temperature of the O2 heater 
load can be estimated. 
 

 

Figure 15 Overview of O2 heater temperature estimation 

The voltage at CFB4 is pulled up to V5DD over R6. The resistance value of R6 can be individually adapted, if 
required. The reference voltage VREF used for the microcontroller ADC can be modified in the Arduino software 

sketch. Figure 16 gives an overview on the tune-able values. 
 

 

Figure 16 ADC measurement setup can be modified to individual needs  
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